GitHub Advisoryadvisory · npm
GHSA-rgg8-g5x8-wr9v Cross-site scripting (XSS) in the clipboard package
MEDIUM
Official page ↗
- Aliases
- CVE-2024-45613
- Ecosystem
- npm
- Packages
- ckeditor5, @ckeditor/ckeditor5-clipboard
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-09-25
Affected packages
• npm ckeditor5: >= 40.0.0, < 43.1.1 → fixed in 43.1.1
• npm @ckeditor/ckeditor5-clipboard: >= 40.0.0, < 43.1.1 → fixed in 43.1.1
Description
Impact
During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration.
This vulnerability affects only installations where the editor configuration meets the following criteria:
1. The Block Toolbar plugin is enabled.
1. One of the following plugins is also enabled:
• General HTML Support with a configuration that permits unsafe markup.
• HTML Embed.
Patches
The problem has been recognized and patched. The fix will be available in version 43.1.1 (and above), and explicitly in version 41.3.2.
Workarounds
It's highly recommended to update to the version 43.1.1 or higher. However, if the update is not an option, we recommend disabling the block toolbar plugin.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Related
Alias · CVE (1)
- CVE-2024-45613 CKEditor 5 is a JavaScript rich-text editor. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness