GitHub Advisoryadvisory · RubyGems

GHSA-rgr4-9jh5-j4j6 Rack vulnerable to Denial of Service via large parameter depth request

MEDIUM Published 2017-10-24 Modified 2023-03-14 Official page ↗
Aliases
CVE-2015-3225
Ecosystem
RubyGems
Packages
rack
Severity
Moderate
Reviewed
2020-06-16

Affected packages

• RubyGems rack: >= 1.5.0, < 1.5.4 → fixed in 1.5.4 • RubyGems rack: >= 1.6.0, < 1.6.2 → fixed in 1.6.2 • RubyGems rack: >= 1.4.0, < 1.4.6 → fixed in 1.4.6

Description

lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.

Related

Alias · CVE (1)

  • CVE-2015-3225 lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote… vulnerability

References