GitHub Advisoryadvisory · Packagist

GHSA-rh3m-pr36-xh2f kelvinmo simplexrd vulnerable to Improper Restriction of XML External Entity Reference

CRITICAL Published 2023-01-07 Modified 2023-01-12 Official page ↗
Aliases
CVE-2015-10029
Ecosystem
Packagist
Packages
kelvinmo/simplexrd
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-611
Reviewed
2023-01-12

Affected packages

• Packagist kelvinmo/simplexrd: < 3.1.1 → fixed in 3.1.1

Description

A vulnerability classified as problematic was found in kelvinmo simplexrd up to 3.1.0. This vulnerability affects unknown code of the file `simplexrd/simplexrd.class.php`. The manipulation leads to xml external entity reference. Upgrading to version 3.1.1 is able to address this issue. The name of the patch is 4c9f2e028523ed705b555eca2c18c64e71f1a35d. It is recommended to upgrade the affected component. VDB-217630 is the identifier assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2015-10029 A vulnerability classified as problematic was found in kelvinmo simplexrd up to 3.1.0. vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References