GitHub Advisoryadvisory · npm

GHSA-rh54-vffm-5fvp CKEditor: Cross-site scripting (XSS) in the engine package

HIGH Published 2026-10-27 Modified 2026-10-27 Official page ↗
Aliases
CVE-2026-116688
Ecosystem
npm
Packages
ckeditor5, @ckeditor/ckeditor5-engine
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2026-10-27

Affected packages

• npm ckeditor5: >= 45.0.0, < 47.7.4 → fixed in 47.7.4 • npm @ckeditor/ckeditor5-engine: >= 45.0.0, < 47.7.4 → fixed in 47.7.4 • npm ckeditor5: >= 48.0.0, < 48.5.1 → fixed in 48.5.1 • npm @ckeditor/ckeditor5-engine: >= 48.0.0, < 48.5.1 → fixed in 48.5.1

Description

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the `es-toolkit` library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming `style` attribute values. The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5. Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS). For more information Email us at [email protected] if you have any questions or comments about this advisory.

Related

Alias · CVE (1)

  • CVE-2026-116688 CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References