GitHub Advisoryadvisory · Packagist
GHSA-rh5w-82wh-jhr8 XSS vulnerability on asset view
HIGH
Official page ↗
- Aliases
- CVE-2021-27912
- Ecosystem
- Packagist
- Packages
- mautic/core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2021-08-30
Affected packages
• Packagist mautic/core: < 3.3.4 → fixed in 3.3.4
• Packagist mautic/core: >= 4.0.0-alpha1, < 4.0.0 → fixed in 4.0.0
Description
Impact
Mautic versions before 3.3.4 / 4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title and adding a broken image URL as a remote asset. This can only be leveraged by an authenticated user with permission to create or edit assets.
Patches
Upgrade to 3.3.4 or 4.0.0
Workarounds
No
References
https://github.com/mautic/mautic/releases/tag/3.3.4
https://github.com/mautic/mautic/releases/tag/4.0.0
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2021-27912 Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness