GitHub Advisoryadvisory · Packagist
GHSA-rh9f-gr6q-mpc4 moonshine Stored Cross-Site Scripting Vulnerability in Create Admin
MEDIUM
Official page ↗
- Aliases
- CVE-2025-51488
- Ecosystem
- Packagist
- Packages
- moonshine/moonshine
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-08-20
Affected packages
• Packagist moonshine/moonshine: < 3.12.14 → fixed in 3.12.14
Description
A stored cross-site scripting (XSS) vulnerability in the Create Admin function of MoonShine v3.12.3 allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload into the Name parameter.
Related
Alias · CVE (1)
- CVE-2025-51488 A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.4, allowing remote attackers to store and execute… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness