GitHub Advisoryadvisory · PyPI
GHSA-rhhj-5436-95vf Code execution in Embedchain
CRITICAL
Official page ↗
- Aliases
- CVE-2024-23731
- Ecosystem
- PyPI
- Packages
- embedchain
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-88, CWE-94
- Reviewed
- 2024-01-22
Affected packages
• PyPI embedchain: < 0.1.57 → fixed in 0.1.57
Description
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument.
Related
Alias · CVE (1)
- CVE-2024-23731 The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-23731 advisory
- https://github.com/embedchain/embedchain/pull/1122 web
- https://github.com/embedchain/embedchain package
- https://github.com/embedchain/embedchain/compare/0.1.56...0.1.57 web
- https://github.com/pypa/advisory-database/tree/main/vulns/embedchain/PYSEC-2024-7.yaml web