GitHub Advisoryadvisory · Maven
GHSA-rhqj-4pp8-vvgf Injection in Jolokia agent
HIGH
Official page ↗
- Aliases
- CVE-2018-1000130
- Ecosystem
- Maven
- Packages
- org.jolokia:jolokia-core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2022-06-30
Affected packages
• Maven org.jolokia:jolokia-core: >= 1.3.7, < 1.5.0 → fixed in 1.5.0
Description
A JNDI Injection vulnerability exists in Jolokia agent version 1.3.7 in the proxy mode that allows a remote attacker to run arbitrary Java code on the server.
Related
Alias · CVE (1)
- CVE-2018-1000130 A JNDI Injection vulnerability exists in Jolokia agent version 1.3.7 in the proxy mode that allows a remote attacker to run arbitrary Java… vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000130 advisory
- https://github.com/rhuss/jolokia/commit/1b360b8889f0ed51165a8d1ac55dd8e0aa2dfd4a web
- https://github.com/rhuss/jolokia/commit/fd7b93da30c61a45bac10d8b311f1b79a74910f5 web
- https://access.redhat.com/errata/RHSA-2018:2669 web
- https://github.com/rhuss/jolokia package
- https://github.com/rhuss/jolokia/releases/tag/v1.5.0 web
- https://jolokia.org/#Security_fixes_with_1.5.0 web