GitHub Advisoryadvisory · Maven

GHSA-rhrv-645h-fjfh Apache Avro Java SDK vulnerable to Improper Input Validation

HIGH Published 2023-09-29 Modified 2025-07-31 Official page ↗
Aliases
CVE-2023-39410
Ecosystem
Maven
Packages
org.apache.avro:avro
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20, CWE-502
Reviewed
2023-09-29

Affected packages

• Maven org.apache.avro:avro: < 1.11.3 → fixed in 1.11.3

Description

When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.

Related

Alias · CVE (1)

  • CVE-2023-39410 When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References