GitHub Advisoryadvisory · npm
GHSA-rhwf-hqpr-q8g2 Code Injection in script-manager
HIGH
Official page ↗
- Aliases
- CVE-2020-8129
- Ecosystem
- npm
- Packages
- script-manager
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2021-04-07
Affected packages
• npm script-manager: < 0.9.0 → fixed in 0.9.0
Description
An unintended require vulnerability in script-manager npm package version 0.8.6 and earlier may allow attackers to execute arbitrary code.
Related
Alias · CVE (1)
- CVE-2020-8129 An unintended require vulnerability in script-manager npm package version 0.8.6 and earlier may allow attackers to execute arbitrary code. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness