GitHub Advisoryadvisory · RubyGems

GHSA-rhwx-hjx2-x4qr PDFKit vulnerable to Command Injection

CRITICAL Published 2022-09-10 Modified 2023-01-26 Official page ↗
Aliases
CVE-2022-25765
Ecosystem
RubyGems
Packages
pdfkit
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2022-09-15

Affected packages

• RubyGems pdfkit: < 0.8.7.2 → fixed in 0.8.7.2

Description

The package pdfkit is vulnerable to Command Injection where the URL is not properly sanitized. Note: This issue was patched in 0.8.7.2, but the patch was discovered to be ineffective. The updated patch version is 0.8.7.2.

Related

Alias · CVE (1)

  • CVE-2022-25765 The package pdfkit from 0.0.0 are vulnerable to Command Injection where the URL is not properly sanitized. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References