GitHub Advisoryadvisory · PyPI
GHSA-rj98-crf4-g69w pgAdmin 4 vulnerable to Unsafe Deserialization and Remote Code Execution by an Authenticated user
CRITICAL
Official page ↗
- Aliases
- CVE-2024-2044
- Ecosystem
- PyPI
- Packages
- pgAdmin4
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-22, CWE-31, CWE-502
- Reviewed
- 2024-03-07
Affected packages
• PyPI pgAdmin4: < 8.4 → fixed in 8.4
Description
pgAdmin prior to version 8.4 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them and gain code execution.
Related
Alias · CVE (1)
- CVE-2024-2044 pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-2044 advisory
- https://github.com/pgadmin-org/pgadmin4/issues/7258 web
- https://github.com/pgadmin-org/pgadmin4/commit/4e49d752fba72953acceeb7f4aa2e6e32d25853d web
- https://github.com/pgadmin-org/pgadmin4 package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV web
- https://www.shielder.com/advisories/pgadmin-path-traversal_leads_to_unsafe_deserialization_and_rce web