GitHub Advisoryadvisory · Maven

GHSA-rjgh-wgc7-m37j Vaadin Vulnerable to Authentication Bypass When Accessing the /VAADIN Endpoint Without a Trailing Slash

MEDIUM Published 2026-03-10 Modified 2026-03-11 Official page ↗
Aliases
CVE-2026-2742
Ecosystem
Maven
Packages
com.vaadin:flow-server, com.vaadin:vaadin
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/S:N/AU:Y/R:A/V:D/RE:L/U:Amber
Weaknesses
CWE-284
Reviewed
2026-03-11

Affected packages

• Maven com.vaadin:flow-server: < 14.14.1 → fixed in 14.14.1 • Maven com.vaadin:flow-server: >= 23.0.0, < 23.6.7 → fixed in 23.6.7 • Maven com.vaadin:flow-server: >= 24.0.0, < 24.9.8 → fixed in 24.9.8 • Maven com.vaadin:flow-server: >= 25.0.0, < 25.0.2 → fixed in 25.0.2 • Maven com.vaadin:vaadin: >= 25.0.0, < 25.0.2 → fixed in 25.0.2 • Maven com.vaadin:vaadin: >= 24.0.0, < 24.9.8 → fixed in 24.9.8 • Maven com.vaadin:vaadin: >= 23.0.0, < 23.6.7 → fixed in 23.6.7 • Maven com.vaadin:vaadin: < 14.14.1 → fixed in 14.14.1

Description

An authentication bypass vulnerability exists in Vaadin 14.0.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.7 and 25.0.0 through 25.0.1, applications using Spring Security due to inconsistent path pattern matching of reserved framework paths. Accessing the /VAADIN endpoint without a trailing slash bypasses security filters, and allowing unauthenticated users to trigger framework initialization and create sessions without proper authorization. Users of affected versions using Spring Security should upgrade as follows: 14.0.0-14.14.0 upgrade to 14.14.1, 23.0.0-23.6.6 to 23.6.7, 24.0.0 - 24.9.7 to 24.9.8, and 25.0.0-25.0.1 upgrade to 25.0.2 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and users should update either to the latest 14, 23, 24, 25 version.

Related

Alias · CVE (1)

  • CVE-2026-2742 An authentication bypass vulnerability exists in Vaadin 14.0.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.7 and 25.0.0… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References