GitHub Advisoryadvisory · npm

GHSA-rjmf-p882-645m mongodb-client-encryption vulnerable to Improper Certificate Validation

MEDIUM Published 2021-04-12 Modified 2024-09-16 Official page ↗
Aliases
CVE-2021-20327
Ecosystem
npm
Packages
mongodb-client-encryption
Severity
Moderate
CVSS vector
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-295
Reviewed
2021-03-16

Affected packages

• npm mongodb-client-encryption: >= 1.2.0, < 1.2.1 → fixed in 1.2.1

Description

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and the KMS service rendering client-side field level encryption (CSFLE) ineffective. This issue was discovered during internal testing and affects mongodb-client-encryption module version 1.2.0, which was available from 2021-Jan-29 and deprecated in the NPM Registry on 2021-Feb-04. This vulnerability does not impact driver traffic payloads with CSFLE-supported key services from applications residing inside the AWS, GCP, and Azure nework fabrics due to compensating controls in these environments. This issue does not impact driver workloads that don’t use Field Level Encryption. This issue affect MongoDB Node.js Driver mongodb-client-encryption module version 1.2.0

Related

Alias · CVE (1)

  • CVE-2021-20327 A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References