GitHub Advisoryadvisory · npm
GHSA-rjvg-8v36-xv9r element-plus vulnerable to cross-site scripting (XSS) via el-table-column
MEDIUM
Official page ↗
- Aliases
- CVE-2022-27103
- Ecosystem
- npm
- Packages
- element-plus
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-04-11
Affected packages
• npm element-plus: < 2.0.6 → fixed in 2.0.6
Description
element-plus below 2.0.5 is vulnerable to Cross Site Scripting (XSS) when attribute `show-tooltips-overflow` of `el-table-column` is true. The mouseover action will make the text of this column render as html.
Related
Alias · CVE (1)
- CVE-2022-27103 element-plus 2.0.5 is vulnerable to Cross Site Scripting (XSS) via el-table-column. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-27103 advisory
- https://github.com/asjdf/element-table-xss-test/issues/1 web
- https://github.com/element-plus/element-plus/issues/6514 web
- https://github.com/element-plus/element-plus/pull/6520 web
- https://github.com/element-plus/element-plus/commit/063c56446135176971f532bd0eb2e88a0b137d43 web
- https://github.com/asjdf/element-table-xss-test web
- https://github.com/element-plus/element-plus package