GitHub Advisoryadvisory · PyPI
GHSA-rm79-x4g6-hvg5 pgAdmin 4 has command injection vulnerability on Windows systems
MEDIUM
Official page ↗
- Aliases
- CVE-2025-12763
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2025-11-13
Affected packages
• PyPI pgadmin4: < 9.10 → fixed in 9.10
Description
pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.
Related
Alias · CVE (1)
- CVE-2025-12763 pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness