GitHub Advisoryadvisory · PyPI
GHSA-rmp7-f2vp-3rq4 Cross-site scripting in SiCKRAGE
MEDIUM
Official page ↗
- Aliases
- CVE-2021-25925
- Ecosystem
- PyPI
- Packages
- sickrage
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-04-13
Affected packages
• PyPI sickrage: >= 4.2.0, < 10.0.11.dev2 → fixed in 10.0.11.dev2
Description
in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.
Related
Alias · CVE (1)
- CVE-2021-25925 in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-25925 advisory
- https://github.com/SiCKRAGE/SiCKRAGE/commit/9f42426727e16609ad3d1337f6637588b8ed28e4 web
- https://github.com/SiCKRAGE/SiCKRAGE package
- https://github.com/pypa/advisory-database/tree/main/vulns/sickrage/PYSEC-2021-147.yaml web
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25925 web