GitHub Advisoryadvisory · Go
GHSA-rmvv-8v8w-rf7x Mattermost doesn't validate user-supplied input in API request handlers
MEDIUM
Official page ↗
- Aliases
- CVE-2026-4646
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-github
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-1287
- Reviewed
- 2026-06-29
Affected packages
• Go github.com/mattermost/mattermost-server: >= 11.6.0, < 11.6.1 → fixed in 11.6.1
• Go github.com/mattermost/mattermost-server: >= 11.5.0, < 11.5.4 → fixed in 11.5.4
• Go github.com/mattermost/mattermost-server: >= 11.4.0, < 11.4.5 → fixed in 11.4.5
• Go github.com/mattermost/mattermost-server: >= 10.11.0, < 10.11.15 → fixed in 10.11.15
• Go github.com/mattermost/mattermost-plugin-github: < 1.0.1-0.20260330164815-c2840e980b3c → fixed in 1.0.1-0.20260330164815-c2840e980b3c
Description
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint. Mattermost Advisory ID: MMSA-2026-00638
Related
Alias · CVE (1)
- CVE-2026-4646 Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API… vulnerability
Weakness · CWE (1)
- CWE-1287 Improper Validation of Specified Type of Input weakness