GitHub Advisoryadvisory · npm, NuGet, RubyGems, Maven

GHSA-rmxg-73gg-4p98 Cross-Site Scripting (XSS) in jquery

MEDIUM Published 2018-01-22 Modified 2021-09-17 Official page ↗
Aliases
CVE-2015-9251
Ecosystem
npm, NuGet, RubyGems, Maven
Packages
jquery, jQuery, jquery-rails, org.webjars.npm:jquery
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• npm jquery: < 1.12.2 → fixed in 1.12.2 • NuGet jQuery: < 1.12.2 → fixed in 1.12.2 • NuGet jQuery: >= 1.12.3, < 3.0.0 → fixed in 3.0.0 • npm jquery: >= 1.12.3, < 3.0.0 → fixed in 3.0.0 • RubyGems jquery-rails: < 4.2.0 → fixed in 4.2.0 • Maven org.webjars.npm:jquery: < 1.12.2 → fixed in 1.12.2 • Maven org.webjars.npm:jquery: >= 1.12.3, < 3.0.0 → fixed in 3.0.0

Description

Affected versions of `jquery` interpret `text/javascript` responses from cross-origin ajax requests, and automatically execute the contents in `jQuery.globalEval`, even when the ajax request doesn't contain the `dataType` option. Recommendation Update to version 3.0.0 or later.

Related

Alias · CVE (1)

  • CVE-2015-9251 jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References