GitHub Advisoryadvisory · PyPI

GHSA-rpc6-h455-3rx5 Celery local privilege escalation vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-06 Official page ↗
Aliases
CVE-2011-4356
Ecosystem
PyPI
Packages
celery
Severity
Moderate
Weaknesses
CWE-269
Reviewed
2024-05-01

Affected packages

• PyPI celery: >= 2.1.0, < 2.2.8 → fixed in 2.2.8 • PyPI celery: >= 2.3.0, < 2.3.4 → fixed in 2.3.4 • PyPI celery: >= 2.4.0, < 2.4.4 → fixed in 2.4.4

Description

Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.

Related

Alias · CVE (1)

  • CVE-2011-4356 Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References