GitHub Advisoryadvisory · Packagist

GHSA-rpc7-gf58-v3x2 Magento Open Source allows Incorrect Authorization

MEDIUM Published 2023-10-13 Modified 2025-03-04 Official page ↗
Aliases
CVE-2023-38218
Ecosystem
Packagist
Packages
magento/community-edition, magento/project-community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-639, CWE-863
Reviewed
2025-03-04

Affected packages

• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-beta2 → fixed in 2.4.7-beta2 • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p3 → fixed in 2.4.6-p3 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p5 → fixed in 2.4.5-p5 • Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p6 → fixed in 2.4.4-p6 • Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)

Description

Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the `V1/customers/me` endpoint to achieve information exposure and privilege escalation.

Related

Alias · CVE (1)

  • CVE-2023-38218 Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected… vulnerability

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-639 Authorization Bypass Through User-Controlled Key weakness
  • CWE-863 Incorrect Authorization weakness

References