GitHub Advisoryadvisory · PyPI

GHSA-rpfv-46xj-5984 Upsonic has vulnerability in Pickle Handler component that can lead to deserialization

LOW Published 2025-06-19 Modified 2025-07-09 Official page ↗
Aliases
CVE-2025-6279
Ecosystem
PyPI
Packages
upsonic
Severity
Low
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20, CWE-502
Reviewed
2025-07-09

Affected packages

• PyPI upsonic: < 0.56.0 → fixed in 0.56.0

Description

A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.

Related

Alias · CVE (1)

  • CVE-2025-6279 A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References