GitHub Advisoryadvisory · PyPI
GHSA-rpv4-63g3-9x23 Radicale is vulnerable to timing oracles and simple bruteforce attacks
HIGH
Official page ↗
- Aliases
- CVE-2017-8342
- Ecosystem
- PyPI
- Packages
- Radicale
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-362
- Reviewed
- 2023-08-04
Affected packages
• PyPI Radicale: < 1.1.2 → fixed in 1.1.2
• PyPI Radicale: >= 2.0.0rc1, < 2.0.0rc2 → fixed in 2.0.0rc2
Description
Radicale before 1.1.2 and 2.0.0rc1 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.
Related
Alias · CVE (1)
- CVE-2017-8342 Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd… vulnerability
Weakness · CWE (1)
- CWE-362 Concurrent Execution using Shared Resource with Improper Synchronization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-8342 advisory
- https://github.com/Kozea/Radicale/commit/059ba8dec1f22ccbeab837e288b3833a099cee2d web
- https://github.com/Kozea/Radicale/commit/190b1dd795f0c552a4992445a231da760211183b web
- https://bugs.debian.org/861514 web
- https://github.com/Kozea/Radicale package
- https://github.com/Kozea/Radicale/blob/1.1.2/NEWS.rst web
- https://github.com/pypa/advisory-database/tree/main/vulns/radicale/PYSEC-2017-102.yaml web
- https://lists.debian.org/debian-lts-announce/2020/04/msg00019.html web