GitHub Advisoryadvisory · Packagist
GHSA-rq36-9f5f-2gw7 Magento Open Source allows SQL Injection
MEDIUM
Official page ↗
- Aliases
- CVE-2023-38249
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-beta2 → fixed in 2.4.7-beta2
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p3 → fixed in 2.4.6-p3
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p5 → fixed in 2.4.5-p5
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p6 → fixed in 2.4.4-p6
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by an Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability that could lead in arbitrary code execution by an admin-privilege authenticated attacker. Exploitation of this issue does not require user interaction and attack complexity is high as it requires knowledge of tooling beyond just using the UI.
Related
Alias · CVE (1)
- CVE-2023-38249 Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness