GitHub Advisoryadvisory · Packagist

GHSA-rq7f-j68f-mqh3 PHP Server Monitor vulnerable to Cross-site Scripting

MEDIUM Published 2024-05-24 Modified 2024-05-24 Official page ↗
Aliases
CVE-2024-5312
Ecosystem
Packagist
Packages
phpservermon/phpservermon
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Weaknesses
CWE-79
Reviewed
2024-05-24

Affected packages

• Packagist phpservermon/phpservermon: < 3.3.0 → fixed in 3.3.0

Description

PHP Server Monitor, version 3.2.0, is vulnerable to an XSS via the /phpservermon-3.2.0/vendor/phpmailer/phpmailer/test_script/index.php page in all visible parameters. An attacker could create a specially crafted URL, send it to a victim and retrieve their session details.

Related

Alias · CVE (1)

  • CVE-2024-5312 PHP Server Monitor, version 3.2.0, is vulnerable to an XSS via the /phpservermon-3.2.0/vendor/phpmailer/phpmailer/test_script/index.php… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References