GitHub Advisoryadvisory · Maven

GHSA-rqj9-cq6j-958r Arbitrary Command Execution in Hadoop

HIGH Published 2018-12-21 Modified 2022-09-14 Official page ↗
Aliases
CVE-2018-11766
Ecosystem
Maven
Packages
org.apache.hadoop:hadoop-main
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Reviewed
2020-06-16

Affected packages

• Maven org.apache.hadoop:hadoop-main: >= 2.7.4, < 2.7.7 → fixed in 2.7.7

Description

In Apache Hadoop 2.7.4 to 2.7.6, the security fix for CVE-2016-6811 is incomplete. A user who can escalate to yarn user can possibly run arbitrary commands as root user.

Related

Alias · CVE (1)

  • CVE-2018-11766 In Apache Hadoop 2.7.4 to 2.7.6, the security fix for CVE-2016-6811 is incomplete. vulnerability

References