GitHub Advisoryadvisory · npm
GHSA-rqjw-p5vr-c695 Basic-auth app bundle credential exposure in gatsby-source-wordpress
HIGH
Official page ↗
- Aliases
- CVE-2021-32770
- Ecosystem
- npm
- Packages
- gatsby-source-wordpress
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200, CWE-522
- Reviewed
- 2021-07-15
Affected packages
• npm gatsby-source-wordpress: < 4.0.8 → fixed in 4.0.8
• npm gatsby-source-wordpress: >= 5.0.0, < 5.9.2 → fixed in 5.9.2
Description
Impact
The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected.
Example affected gatsby-config.js:
```
resolve: 'gatsby-source-wordpress',
auth: {
htaccess: {
username: leaked_username
password: leaked_password,
},
},
```
Patches
A patch has been introduced in [email protected] and [email protected] which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`.
Workarounds
There is no known workaround at this time, other than manually editing the app.js file post-build.
For more information
Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2021-32770 Gatsby is a framework for building websites. vulnerability