GitHub Advisoryadvisory · PyPI
GHSA-rqxp-6926-hphr MoinMoin vulnerable to privilege escalation
HIGH
Official page ↗
- Aliases
- CVE-2008-1937
- Ecosystem
- PyPI
- Packages
- moin
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2024-02-09
Affected packages
• PyPI moin: < 1.6.3 → fixed in 1.6.3
Description
The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a non-empty superusers list, does not properly manage users, which allows remote attackers to gain privileges.
Related
Alias · CVE (1)
- CVE-2008-1937 The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a non-empty superusers list, does not properly manage… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2008-1937 advisory
- https://exchange.xforce.ibmcloud.com/vulnerabilities/41909 web
- https://github.com/moinwiki/moin package
- https://github.com/pypa/advisory-database/tree/main/vulns/moin/PYSEC-2008-12.yaml web
- https://web.archive.org/web/20080628213526/http://secunia.com/advisories/29894 web
- https://web.archive.org/web/20080724211750/http://www.securityfocus.com/bid/28869 web
- https://web.archive.org/web/20081002145815/http://hg.moinmo.in/moin/1.6/rev/f405012e67af web
- https://web.archive.org/web/20081007072837/http://secunia.com/advisories/30160 web
- http://moinmo.in/SecurityFixes web
- http://security.gentoo.org/glsa/glsa-200805-09.xml web