GitHub Advisoryadvisory · Packagist
GHSA-rr2g-rrjj-xw86 Magento Improper Authorization vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-27188
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-285, CWE-863
- Reviewed
- 2025-05-01
Affected packages
• Packagist magento/community-edition: < 2.4.4-p13 → fixed in 2.4.4-p13
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p12 → fixed in 2.4.5-p12
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p10 → fixed in 2.4.6-p10
• Packagist magento/community-edition: >= 2.4.7-p1, < 2.4.7-p5 → fixed in 2.4.7-p5
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8 → fixed in 2.4.8
Description
Magento versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-27188 Adobe Commerce versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Improper Authorization… vulnerability