GitHub Advisoryadvisory · Maven

GHSA-rr59-h6rh-v84v Apache Zeppelin SAP: connecting to a malicious SAP server allowed it to perform XXE

MEDIUM Published 2024-04-09 Modified 2024-05-02 Official page ↗
Aliases
CVE-2022-47894
Ecosystem
Maven
Packages
org.apache.zeppelin:sap
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-20, CWE-611
Reviewed
2024-04-09

Affected packages

• Maven org.apache.zeppelin:sap: >= 0.8.0, < 0.11.0 → fixed in 0.11.0

Description

Improper Input Validation vulnerability in Apache Zeppelin SAP. This issue affects Apache Zeppelin SAP: from 0.8.0 before 0.11.0. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users. For more information, the fix already was merged in the source code but Zeppelin decided to retire the SAP component NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Related

Alias · CVE (1)

  • CVE-2022-47894 Improper Input Validation vulnerability in Apache Zeppelin SAP.This issue affects Apache Zeppelin SAP: from 0.8.0 before 0.11.0. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References