GitHub Advisoryadvisory · Maven

GHSA-rrfq-g5fq-fc9c Improper Authentication in hive:hive-exec

HIGH Published 2018-11-21 Modified 2022-09-14 Official page ↗
Aliases
CVE-2018-11777
Ecosystem
Maven
Packages
org.apache.hive:hive-exec
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Reviewed
2020-06-16

Affected packages

• Maven org.apache.hive:hive-exec: >= 3.0.0, < 3.1.1 → fixed in 3.1.1 • Maven org.apache.hive:hive-exec: < 2.3.4 → fixed in 2.3.4

Description

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Related

Alias · CVE (1)

  • CVE-2018-11777 In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if… vulnerability

References