GitHub Advisoryadvisory · PyPI
GHSA-rrmf-rvhw-rf47 PyTorch is vulnerable to memory corruption through its torch.jit.script function
LOW
Official page ↗
- Aliases
- CVE-2025-3000
- Ecosystem
- PyPI
- Packages
- torch
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-119
- Reviewed
- 2026-06-10
Affected packages
• PyPI torch: < 2.13.0 → fixed in 2.13.0
Description
A vulnerability classified as critical has been found in PyTorch 2.6.0. This affects the function torch.jit.script. The manipulation leads to memory corruption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used.
Related
Alias · CVE (1)
- CVE-2025-3000 A vulnerability classified as critical has been found in PyTorch 2.6.0. vulnerability
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-3000 advisory
- https://github.com/pytorch/pytorch/issues/149623 web
- https://github.com/pytorch/pytorch/issues/149623#issue-2935703015 web
- https://github.com/pytorch/pytorch/commit/b90c94991cdf8b87c8f7439f79518e0ef2c4ca4f web
- https://github.com/pypa/advisory-database/tree/main/vulns/torch/PYSEC-2025-194.yaml web
- https://github.com/pytorch/pytorch package
- https://vuldb.com/?ctiid.302049 web
- https://vuldb.com/?id.302049 web
- https://vuldb.com/?submit.524197 web