GitHub Advisoryadvisory · Maven
GHSA-rrpm-pj7p-7j9q Spring Security OAuth vulnerable to remote code execution (RCE)
CRITICAL
Official page ↗
- Aliases
- CVE-2018-1260
- Ecosystem
- Maven
- Packages
- org.springframework.security.oauth:spring-security-oauth2
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2020-06-16
Affected packages
• Maven org.springframework.security.oauth:spring-security-oauth2: >= 2.3.0, < 2.3.3 → fixed in 2.3.3
• Maven org.springframework.security.oauth:spring-security-oauth2: >= 2.2.0, < 2.2.2 → fixed in 2.2.2
• Maven org.springframework.security.oauth:spring-security-oauth2: >= 2.1.0, < 2.1.2 → fixed in 2.1.2
• Maven org.springframework.security.oauth:spring-security-oauth2: >= 2.0.0, < 2.0.15 → fixed in 2.0.15
• Maven org.springframework.security.oauth:spring-security-oauth2: >= 1.0.0, <= 1.0.5 (no fix yet)
Description
Spring Security OAuth versions prior to 2.3.3, prior to 2.2.2, prior to 2.1.2, and prior to 2.0.15 contain a remote code execution vulnerability. An attacker can craft an authorization request to the authorization endpoint that can lead to remote code execution when the resource owner is forwarded to the approval endpoint.
Related
Alias · CVE (1)
- CVE-2018-1260 Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1260 advisory
- https://access.redhat.com/errata/RHSA-2018:1809 web
- https://access.redhat.com/errata/RHSA-2018:2939 web
- https://github.com/advisories/GHSA-rrpm-pj7p-7j9q advisory
- https://github.com/spring-attic/spring-security-oauth package
- https://pivotal.io/security/cve-2018-1260 web
- https://web.archive.org/web/20200227123539/http://www.securityfocus.com/bid/104158 web