GitHub Advisoryadvisory · Maven
GHSA-rrvf-5w4r-3x7v Apache Zeppelin vulnerable to cross-site scripting in the helium module
MEDIUM
Official page ↗
- Aliases
- CVE-2024-31868
- Ecosystem
- Maven
- Packages
- org.apache.zeppelin:zeppelin-interpreter
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-116, CWE-79
- Reviewed
- 2024-04-11
Affected packages
• Maven org.apache.zeppelin:zeppelin-interpreter: >= 0.8.2, < 0.11.1 → fixed in 0.11.1
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin.
Attackers can modify `helium.json` and perform cross-site scripting attacks on normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2024-31868 Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-31868 advisory
- https://github.com/apache/zeppelin/pull/4728 web
- https://github.com/apache/zeppelin/commit/83685795e0ec8d3059fd7a3dbcae5c0532b63b79 web
- https://github.com/apache/zeppelin package
- https://lists.apache.org/thread/55mqs673plsxmgnq7fdf2flftpllyf11 web
- http://www.openwall.com/lists/oss-security/2024/04/09/11 web