GitHub Advisoryadvisory · Packagist

GHSA-rv57-479x-x4qv phpMyAdmin Code Injection vulnerability

CRITICAL Published 2022-05-17 Modified 2025-04-14 Official page ↗
Aliases
CVE-2016-5734
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2025-04-14

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0.10.0, < 4.0.10.16 → fixed in 4.0.10.16 • Packagist phpmyadmin/phpmyadmin: >= 4.4.15.0, < 4.4.15.7 → fixed in 4.4.15.7 • Packagist phpmyadmin/phpmyadmin: >= 4.6.0, < 4.6.3 → fixed in 4.6.3

Description

phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.

Related

Alias · CVE (1)

  • CVE-2016-5734 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References