GitHub Advisoryadvisory · Packagist
GHSA-rv62-6f56-j83w Moodle Oauth 2 Insufficiently Protects Against Compromise
CRITICAL
Official page ↗
- Aliases
- CVE-2019-14880
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2023-07-18
Affected packages
• Packagist moodle/moodle: >= 3.7.0, < 3.7.3 → fixed in 3.7.3
• Packagist moodle/moodle: >= 3.6.0, < 3.6.7 → fixed in 3.6.7
• Packagist moodle/moodle: >= 3.5.0, < 3.5.9 → fixed in 3.5.9
Description
A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.
Related
Alias · CVE (1)
- CVE-2019-14880 A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness