GitHub Advisoryadvisory · Maven
GHSA-rv64-5gf8-9qq8 Apache Tomcat has an Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve
HIGH
Official page ↗
- Aliases
- CVE-2026-34483
- Ecosystem
- Maven
- Packages
- org.apache.tomcat:tomcat-catalina, org.apache.tomcat:tomcat, org.apache.tomcat.embed:tomcat-embed-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-116
- Reviewed
- 2026-04-10
Affected packages
• Maven org.apache.tomcat:tomcat-catalina: >= 9.0.40, < 9.0.116 → fixed in 9.0.116
• Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.54 → fixed in 10.1.54
• Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.21 → fixed in 11.0.21
• Maven org.apache.tomcat:tomcat: >= 9.0.40, < 9.0.116 → fixed in 9.0.116
• Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.54 → fixed in 10.1.54
• Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.21 → fixed in 11.0.21
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.40, < 9.0.116 → fixed in 9.0.116
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.54 → fixed in 10.1.54
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.21 → fixed in 11.0.21
Description
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116.
Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.
Related
Alias · CVE (1)
- CVE-2026-34483 Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat. vulnerability
Weakness · CWE (1)
- CWE-116 Improper Encoding or Escaping of Output weakness