GitHub Advisoryadvisory · npm
GHSA-rv78-f8rc-xrxh Facebook React has a Denial of Service Vulnerability in React Server Components
HIGH
Official page ↗
- Aliases
- CVE-2026-23870
- Ecosystem
- npm
- Packages
- react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400, CWE-770
- Reviewed
- 2026-05-11
Affected packages
• npm react-server-dom-parcel: >= 19.0.0, < 19.0.6 → fixed in 19.0.6
• npm react-server-dom-turbopack: >= 19.0.0, < 19.0.6 → fixed in 19.0.6
• npm react-server-dom-webpack: >= 19.0.0, < 19.0.6 → fixed in 19.0.6
• npm react-server-dom-parcel: >= 19.1.0, < 19.1.7 → fixed in 19.1.7
• npm react-server-dom-turbopack: >= 19.1.0, < 19.1.7 → fixed in 19.1.7
• npm react-server-dom-webpack: >= 19.1.0, < 19.1.7 → fixed in 19.1.7
• npm react-server-dom-parcel: >= 19.2.0, < 19.2.6 → fixed in 19.2.6
• npm react-server-dom-turbopack: >= 19.2.0, < 19.2.6 → fixed in 19.2.6
• npm react-server-dom-webpack: >= 19.2.0, < 19.2.6 → fixed in 19.2.6
Description
Impact
A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to out-of-memory exceptions or excessive CPU usage.
We recommend updating immediately.
The vulnerability exists in versions 19.0.0 through 19.0.5, 19.1.0 through 19.1.6, and 19.2.0 through 19.2.5 of:
react-server-dom-webpack
react-server-dom-parcel
react-server-dom-turbopack
Patches
Fixes were back ported to versions 19.0.6, 19.1.7, and 19.2.6.
If you are using any of the above packages please upgrade to any of the fixed versions immediately.
If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability.
References
See the blog post for more information and upgrade instructions.
Related
Alias · CVE (1)
- CVE-2026-23870 A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could… vulnerability
References
- https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh web
- https://github.com/vercel/next.js/security/advisories/GHSA-8h8q-6873-q5fj web
- https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-w94c-4vhp-22gx web
- https://nvd.nist.gov/vuln/detail/CVE-2026-23870 advisory
- https://github.com/facebook/react package