GitHub Advisoryadvisory · Maven
GHSA-rvg5-f5fj-mxvg Cross-site Scripting in Jenkins Credentials Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29036
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:credentials
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-04-22
Affected packages
• Maven org.jenkins-ci.plugins:credentials: < 2.6.1.1 → fixed in 2.6.1.1
• Maven org.jenkins-ci.plugins:credentials: >= 2.6.2, < 1074.1076.v39c30cecb_0e2 → fixed in 1074.1076.v39c30cecb_0e2
• Maven org.jenkins-ci.plugins:credentials: >= 1087.v16065d268466, < 1087.1089.v2f1b_9a_b_040e4 → fixed in 1087.1089.v2f1b_9a_b_040e4
• Maven org.jenkins-ci.plugins:credentials: >= 1105, <= 1111.v35a (no fix yet)
Description
Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Related
Alias · CVE (1)
- CVE-2022-29036 Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness