GitHub Advisoryadvisory · Maven
GHSA-rvh4-g2rj-hr9c Path Traversal in Jenkins Warnings Next Generation Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-23107
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:warnings-ng
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2022-01-20
Affected packages
• Maven io.jenkins.plugins:warnings-ng: >= 9.8.0, < 9.10.3 → fixed in 9.10.3
• Maven io.jenkins.plugins:warnings-ng: >= 9.6.0, < 9.7.1 → fixed in 9.7.1
• Maven io.jenkins.plugins:warnings-ng: >= 9.1.0, < 9.5.2 → fixed in 9.5.2
• Maven io.jenkins.plugins:warnings-ng: < 9.0.2 → fixed in 9.0.2
Description
Jenkins Warnings Next Generation Plugin prior to 9.10.3, 9.7.1, 9.5.2, and 9.0.2 does not restrict the name of a file when configuring a custom ID.
This allows attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
Jenkins Warnings Next Generation Plugin 9.10.3, 9.7.1, 9.5.2, and 9.0.2 checks for the presence of prohibited directory separator characters in the custom ID.
Related
Alias · CVE (1)
- CVE-2022-23107 Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23107 advisory
- https://github.com/CVEProject/cvelist/blob/36f932156733baab1b13868be4338de406a1dec7/2022/23xxx/CVE-2022-23107.json web
- https://github.com/jenkinsci/warnings-ng-plugin package
- https://github.com/jenkinsci/warnings-ng-plugin/releases/tag/v9.10.3 web
- https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2090 web
- http://www.openwall.com/lists/oss-security/2022/01/12/6 web