GitHub Advisoryadvisory · Packagist
GHSA-rvmc-8gmg-ggqr Moodle Blind SQL injection possible via MNet authentication
HIGH
Official page ↗
- Aliases
- CVE-2021-32474
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.10, < 3.10.4 → fixed in 3.10.4
• Packagist moodle/moodle: >= 3.9, < 3.9.7 → fixed in 3.9.7
• Packagist moodle/moodle: >= 3.8, < 3.8.9 → fixed in 3.8.9
• Packagist moodle/moodle: >= 3.5, < 3.5.18 → fixed in 3.5.18
Description
An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Related
Alias · CVE (1)
- CVE-2021-32474 An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness