GitHub Advisoryadvisory · RubyGems
GHSA-rvpq-5xqx-pfpp Ruby on Rails vulnerable to code injection
HIGH
Official page ↗
- Aliases
- CVE-2006-4111
- Ecosystem
- RubyGems
- Packages
- rails
- Severity
- High
- Weaknesses
- CWE-94
- Reviewed
- 2020-06-16
Affected packages
• RubyGems rails: >= 1.1.0, < 1.1.6 → fixed in 1.1.6
Description
Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.
Related
Alias · CVE (1)
- CVE-2006-4111 Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2006-4111 advisory
- https://github.com/presidentbeef/rails-security-history/blob/master/vulnerabilities.md web
- https://github.com/rails/rails package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2006-4111.yml web
- https://web.archive.org/web/20200301174340/http://www.securityfocus.com/bid/19454 web
- https://web.archive.org/web/20200808083046/http://securitytracker.com/id?1016673 web
- http://blog.koehntopp.de/archives/1367-Ruby-On-Rails-Mandatory-Mystery-Patch.html web
- http://weblog.rubyonrails.org/2006/8/9/rails-1-1-5-mandatory-security-patch-and-other-tidbits web
- http://www.gentoo.org/security/en/glsa/glsa-200608-20.xml web
- http://www.novell.com/linux/security/advisories/2006_21_sr.html web