GitHub Advisoryadvisory · PyPI

GHSA-rvqx-wpfh-mfx7 Langflow Unauth RCE

CRITICAL Published 2025-06-17 Modified 2026-10-27 Official page ↗
Aliases
CVE-2025-3248
Ecosystem
PyPI
Packages
langflow, langflow-base
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A
Weaknesses
CWE-94
Reviewed
2025-06-17

Affected packages

• PyPI langflow: < 1.3.0 → fixed in 1.3.0 • PyPI langflow-base: < 0.3.0 → fixed in 0.3.0

Description

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.

Related

Alias · CVE (1)

  • CVE-2025-3248 Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References