GitHub Advisoryadvisory · Packagist

GHSA-rw54-6826-c8j5 yiisoft/yii2-authclient's Oauth2 PKCE implementation is vulnerable

MEDIUM Published 2023-12-18 Modified 2023-12-22 Official page ↗
Aliases
CVE-2023-50714
Ecosystem
Packagist
Packages
yiisoft/yii2-authclient
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-287, CWE-347
Reviewed
2023-12-18

Affected packages

• Packagist yiisoft/yii2-authclient: < 2.2.15 → fixed in 2.2.15

Description

Impact _What kind of vulnerability is it? Who is impacted?_ Original Report: > The Oauth2 PKCE implementation is vulnerable in 2 ways: > 1. The `authCodeVerifier` should be removed after usage (similar to 'authState') > 2. There is a risk for a "downgrade attack" if PKCE is being relied on for CSRF protection. Patches _Has the problem been patched? What versions should users upgrade to?_ 2.2.15 Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ not known yet. References _Are there any links users can visit to find out more?_

Related

Alias · CVE (1)

  • CVE-2023-50714 yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-347 Improper Verification of Cryptographic Signature weakness

References