GitHub Advisoryadvisory · Maven
GHSA-rwf9-8fqr-p44m Qualys Jenkins Plugin for Policy Compliance Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-6148
- Ecosystem
- Maven
- Packages
- com.qualys.plugins:qualys-pc
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-12
Affected packages
• Maven com.qualys.plugins:qualys-pc: < 1.0.6 → fixed in 1.0.6
Description
Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data.
Related
Alias · CVE (1)
- CVE-2023-6148 Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness