GitHub Advisoryadvisory · Packagist
GHSA-rwgm-f83r-v3qj Improper Certificate Validation in WP-CLI framework
CRITICAL
Official page ↗
- Aliases
- CVE-2021-29504
- Ecosystem
- Packagist
- Packages
- wp-cli/wp-cli
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2021-05-19
Affected packages
• Packagist wp-cli/wp-cli: >= 0.12.0, < 2.5.0 → fixed in 2.5.0
Description
Impact
An improper error handling in HTTPS requests management in WP-CLI version 0.12.0 and later allows remote attackers able to intercept the communication to remotely disable the certificate verification on WP-CLI side, gaining full control over the communication content, including the ability to impersonate update servers and push malicious updates towards WordPress instances controlled by the vulnerable WP-CLI agent, or push malicious updates toward WP-CLI itself.
Patches
The vulnerability stems from the fact that the default behavior of `WP_CLI\Utils\http_request()` when encountering a TLS handshake error is to disable certificate validation and retry the same request.
The default behavior has been changed with version 2.5.0 of WP-CLI and the `wp-cli/wp-cli` framework (via https://github.com/wp-cli/wp-cli/pull/5523) so that the `WP_CLI\Utils\http_request()` method accepts an `$insecure` option that is `false` by default and consequently that a TLS handshake failure is a hard error by default. This new default is a breaking change and ripples through to all consumers of `WP_CLI\Utils\http_request()`, including those in separate WP-CLI bundled or third-party packages.
https://github.com/wp-cli/wp-cli/pull/5523 has also added an `--insecure` flag to the `cli update` command to counter this breaking change.
Subsequent PRs on the command repositories have added an `--insecure` flag to the appropriate commands on the following repositories to counter the breaking change:
• https://github.com/wp-cli/config-command/pull/128
• https://github.com/wp-cli/core-command/pull/186
• https://github.com/wp-cli/extension-command/pull/287
• https://github.com/wp-cli/checksum-command/pull/86
• https://github.com/wp-cli/package-command/pull/138
Workarounds
There is no direct workaround for the default insecure behavior of `wp-cli/wp-cli` versions before 2.5.0.
The workaround for dealing with the breaking change in the commands directly affected by the new secure default behavior is to add the `--insecure` flag to manually opt-in to the previous insecure behavior.
References
• CWE: Improper Certificate Validation
For more information
If you have any questions or comments about this advisory:
• Join the `#cli` channel in the WordPress.org Slack to ask questions or provide feedback.
Related
Alias · CVE (1)
- CVE-2021-29504 WP-CLI is the command-line interface for WordPress. vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/wp-cli/wp-cli/security/advisories/GHSA-rwgm-f83r-v3qj web
- https://nvd.nist.gov/vuln/detail/CVE-2021-29504 advisory
- https://github.com/wp-cli/checksum-command/pull/86 web
- https://github.com/wp-cli/config-command/pull/128 web
- https://github.com/wp-cli/core-command/pull/186 web
- https://github.com/wp-cli/extension-command/pull/287 web
- https://github.com/wp-cli/package-command/pull/138 web
- https://github.com/wp-cli/wp-cli/pull/5523 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/wp-cli/wp-cli/CVE-2021-29504.yaml web