GitHub Advisoryadvisory · Maven
GHSA-rwh9-8xx8-4wfm Cross-site Scripting in OpenCRX
MEDIUM
Official page ↗
- Aliases
- CVE-2021-25959
- Ecosystem
- Maven
- Packages
- org.opencrx:opencrx-core, org.opencrx:opencrx-core-models, org.opencrx:opencrx-core-config, org.opencrx:opencrx-client, org.opencrx:opencrx-gradle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-09-30
Affected packages
• Maven org.opencrx:opencrx-core: >= 4.0.0, < 5.2.0 → fixed in 5.2.0
• Maven org.opencrx:opencrx-core-models: >= 4.0.0, < 5.2.0 → fixed in 5.2.0
• Maven org.opencrx:opencrx-core-config: >= 4.0.0, < 5.2.0 → fixed in 5.2.0
• Maven org.opencrx:opencrx-client: >= 4.0.0, < 5.2.0 → fixed in 5.2.0
• Maven org.opencrx:opencrx-gradle: >= 4.0.0, < 5.2.0 → fixed in 5.2.0
Description
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Related
Alias · CVE (1)
- CVE-2021-25959 In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness