GitHub Advisoryadvisory · Packagist

GHSA-v273-j5hq-26xp Drupal core uses a vulnerable Third-party library CKEditor

MEDIUM Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
drupal/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
Reviewed
2024-05-15

Affected packages

• Packagist drupal/core: >= 8.0.0, < 8.7.12 → fixed in 8.7.12 • Packagist drupal/core: >= 8.8.0, < 8.8.4 → fixed in 8.8.4

Description

The Drupal project uses the third-party library CKEditor, which has released a security improvement that is needed to protect some Drupal configurations. Vulnerabilities are possible if Drupal is configured to use the WYSIWYG CKEditor for your site's users. An attacker that can create or edit content may be able to exploit this Cross Site Scripting (XSS) vulnerability to target users with access to the WYSIWYG CKEditor, and this may include site admins with privileged access. The latest versions of Drupal update CKEditor to 4.14 to mitigate the vulnerabilities.

References