GitHub Advisoryadvisory · Maven
GHSA-v27q-87jf-j9cr Jenkins Pipeline Aggregator View Plugin vulnerable to Cross-site Scripting
HIGH
Official page ↗
- Aliases
- CVE-2023-28670
- Ecosystem
- Maven
- Packages
- com.paul8620.jenkins.plugins:pipeline-aggregator-view
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2023-04-03
Affected packages
• Maven com.paul8620.jenkins.plugins:pipeline-aggregator-view: < 1.14 → fixed in 1.14
Description
Jenkins Pipeline Aggregator View Plugin 1.13 and earlier does not escape a variable representing the current view's URL in inline JavaScript, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by authenticated attackers with Overall/Read permission. Version 1.14 obtains the current URL in a way not susceptible to XSS.
Related
Alias · CVE (1)
- CVE-2023-28670 Jenkins Pipeline Aggregator View Plugin 1.13 and earlier does not escape a variable representing the current view's URL in inline… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness