GitHub Advisoryadvisory · PyPI
GHSA-v2p7-4pv4-3wwh Infrahub: Deleted and expired API tokens can still authenticate
MEDIUM
Official page ↗
- Aliases
- CVE-2025-59036
- Ecosystem
- PyPI
- Packages
- infrahub-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-298
- Reviewed
- 2025-09-10
Affected packages
• PyPI infrahub-server: < 1.3.9 → fixed in 1.3.9
• PyPI infrahub-server: >= 1.4.0, < 1.4.5 → fixed in 1.4.5
Description
Impact
A bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully.
Patches
This issue is fixed in versions `1.3.9` and `1.4.5`
Workarounds
Users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.
Related
Alias · CVE (1)
- CVE-2025-59036 Infrahub offers a central hub to manage data, templates, and playbooks. vulnerability
Weakness · CWE (1)
- CWE-298 Improper Validation of Certificate Expiration weakness
References
- https://github.com/opsmill/infrahub/security/advisories/GHSA-v2p7-4pv4-3wwh web
- https://nvd.nist.gov/vuln/detail/CVE-2025-59036 advisory
- https://github.com/opsmill/infrahub/commit/215185f217e2f754f7c0a0aa4b77e11079a063a1 web
- https://github.com/opsmill/infrahub/commit/61b49a4a9e988f10c3a44f0e86ef97f344a1e228 web
- https://github.com/opsmill/infrahub package
- https://github.com/opsmill/infrahub/releases/tag/infrahub-v1.3.9 web
- https://github.com/opsmill/infrahub/releases/tag/infrahub-v1.4.5 web